HDOJ—-输入输出练习之A+B

最近在杭电刷题分享一些过了的源码,虽然不算高效简洁,但对于没有基础的初学者是个很好的帮助…….

关于题目是英语的问题,网上可以很容易搜到汉语版本的,但推荐看英语,因为坑爹的考试全部是英语题目,所以慢慢适应吧……

A+B for Input-Output Practice (I)

Problem Description

Your task is to Calculate a + b.
Too easy?! Of course! I specially designed the problem for acm beginners.
You must have found that some problems have the same titles with this one, yes, all these problems were designed for the same aim.

Input

The input will consist of a series of pairs of integers a and b, separated by a space, one pair of integers per line.

Output

For each pair of input integers a and b you should output the sum of a and b in one line, and with one line of output for each line in input.

Sample Input

1 5
10 20

Sample Output

6
30

Author

lcy

Recommend

JGShining

以下为c语言源码……………

[sourcecode language=”c”]
#include<stdio.h>
int main()
{
int a,b;
while(scanf("%d%d",&a,&b)!=EOF)
{
printf("%d\n",a+b);
}
return 0;
}
[/sourcecode]

A+B for Input-Output Practice (II)

Problem Description

Your task is to Calculate a + b.

Input

Input contains an integer N in the first line, and then N lines follow. Each line consists of a pair of integers a and b, separated by a space, one pair of integers per line.

Output

For each pair of input integers a and b you should output the sum of a and b in one line, and with one line of output for each line in input.

Sample Input

2

1 5

10 20

Sample Output

6
30

Author

lcy

Recommend

JGShining

以下为c语言源码……………

[php]
#include<stdio.h>
int main()
{
int i,n,a,b;
scanf("%d",&n);
for(i=0;i<n;i++)
{
scanf("%d%d",&a,&b);
printf("%d\n",a+b);
}
return 0;
}
[/php]

A+B for Input-Output Practice (III)

Problem Description

Your task is to Calculate a + b.

Input

Input contains multiple test cases. Each test case contains a pair of integers a and b, one pair of integers per line. A test case containing 0 0 terminates the input and this test case is not to be processed.

Output

For each pair of input integers a and b you should output the sum of a and b in one line, and with one line of output for each line in input.

Sample Input

1 5
10 20
0 0

Sample Output

6
30

Author

lcy

Recommend

JGShining

以下为c语言源码……………

[php]
#include<stdio.h>
int main()
{
int a,b;
while(scanf("%d%d",&a,&b),(a!=0||b!=0))
{
printf("%d\n",a+b);
}
return 0;
}
[/php]

A+B for Input-Output Practice (IV)

Problem Description

Your task is to Calculate the sum of some integers.

Input

Input contains multiple test cases. Each test case contains a integer N, and then N integers follow in the same line. A test case starting with 0 terminates the input and this test case is not to be processed.

Output

For each group of input integers you should output their sum in one line, and with one line of output for each line in input.

Sample Input

4 1 2 3 4
5 1 2 3 4 5
0

Sample Output

10
15

Author

lcy

Recommend

JGShining

以下为c语言源码……………

[php]
#include<stdio.h>
int main()
{
int i,ans,n,t;
while(scanf("%d",&n),n!=0)
{
ans=0;
for(i=0;i<n;i++)
{
scanf("%d",&t);
ans+=t;
}
printf("%d\n",ans);
}
return 0;
}
[/php]

A+B for Input-Output Practice (V)

Problem Description

Your task is to calculate the sum of some integers.

Input

Input contains an integer N in the first line, and then N lines follow. Each line starts with a integer M, and then M integers follow in the same line.

Output

For each group of input integers you should output their sum in one line, and with one line of output for each line in input.

Sample Input

2
4 1 2 3 4
5 1 2 3 4 5

Sample Output

10
15

Author

lcy

以下为c语言源码……………

[php]
#include<stdio.h>
int main()
{
int i,j,n,m,t,ans;
scanf("%d",&n);
for(i=0;i<n;i++)
{
scanf("%d",&m);
ans=0;
for(j=0;j<m;j++)
{
scanf("%d",&t);
ans+=t;
}
printf("%d\n",ans);
}
return 0;
}
[/php]

A+B for Input-Output Practice (VI)

Problem Description

Your task is to calculate the sum of some integers.

Input

Input contains multiple test cases, and one case one line. Each case starts with an integer N, and then N integers follow in the same line.

Output

For each test case you should output the sum of N integers in one line, and with one line of output for each line in input.

Sample Input

4 1 2 3 4
5 1 2 3 4 5

Sample Output

10
15

Author

lcy

Recommend

JGShining

以下为c语言源码……………

[php]
#include<stdio.h>
int main()
{
int i,ans,n,t;
while(scanf("%d",&n)!=EOF)
{
ans=0;
for(i=0;i<n;i++)
{
scanf("%d",&t);
ans+=t;
}
printf("%d\n",ans);
}
return 0;
}
[/php]

A+B for Input-Output Practice (VII)

Problem Description

Your task is to Calculate a + b.

Input

The input will consist of a series of pairs of integers a and b, separated by a space, one pair of integers per line.

Output

For each pair of input integers a and b you should output the sum of a and b, and followed by a blank line.

Sample Input

1 5
10 20

Sample Output

6 30

author

lcy

Recommend

JGShining

以下为c语言源码……………

[php]
#include<stdio.h>
int main()
{
int ans,a,b,t;
while(scanf("%d%d",&a,&b)!=EOF)
{
printf("%d\n\n",a+b);
}
return 0;
}
[/php]

A+B for Input-Output Practice (VIII)

Problem Description

Your task is to calculate the sum of some integers.

Input

Input contains an integer N in the first line, and then N lines follow. Each line starts with a integer M, and then M integers follow in the same line.

Output

For each group of input integers you should output their sum in one line, and you must note that there is a blank line between outputs.

Sample Input

3
4 1 2 3 4
5 1 2 3 4 5
3 1 2 3

Sample Output

10
15
6

Author

lcy

Recommend

JGShining

以下为c语言源码……………

[php]
#include<stdio.h>
int main()
{
int i,j,n,m,t,ans;
scanf("%d",&n);
while (n–)
{
scanf("%d",&m);
ans=0;
while (m–)
{
scanf("%d",&t);
ans+=t;
}
printf("%d\n",ans);
if(n!=0)printf("\n");
}
return 0;
}
[/php]

1 comment

  1. imeilige Reply
    November 10, 2012 at 8:09 am

    谢谢 对我太有帮助了

Leave A Comment Cancel reply

Please be polite. We appreciate that. Your email address will not be published and required fields are marked