最近在杭电刷题分享一些过了的源码,虽然不算高效简洁,但对于没有基础的初学者是个很好的帮助…….
关于题目是英语的问题,网上可以很容易搜到汉语版本的,但推荐看英语,因为坑爹的考试全部是英语题目,所以慢慢适应吧……
A+B for Input-Output Practice (I)
Problem Description
Too easy?! Of course! I specially designed the problem for acm beginners.
You must have found that some problems have the same titles with this one, yes, all these problems were designed for the same aim.
Input
Output
Sample Input
Sample Output
Author
Recommend
以下为c语言源码……………
[sourcecode language=”c”]
#include<stdio.h>
int main()
{
int a,b;
while(scanf("%d%d",&a,&b)!=EOF)
{
printf("%d\n",a+b);
}
return 0;
}
[/sourcecode]
A+B for Input-Output Practice (II)
Problem Description
Input
Output
Sample Input
2
1 5
Sample Output
Author
Recommend
以下为c语言源码……………
[php]
#include<stdio.h>
int main()
{
int i,n,a,b;
scanf("%d",&n);
for(i=0;i<n;i++)
{
scanf("%d%d",&a,&b);
printf("%d\n",a+b);
}
return 0;
}
[/php]
A+B for Input-Output Practice (III)
Problem Description
Input
Output
Sample Input
Sample Output
Author
Recommend
以下为c语言源码……………
[php]
#include<stdio.h>
int main()
{
int a,b;
while(scanf("%d%d",&a,&b),(a!=0||b!=0))
{
printf("%d\n",a+b);
}
return 0;
}
[/php]
A+B for Input-Output Practice (IV)
Problem Description
Input
Output
Sample Input
Sample Output
Author
Recommend
以下为c语言源码……………
[php]
#include<stdio.h>
int main()
{
int i,ans,n,t;
while(scanf("%d",&n),n!=0)
{
ans=0;
for(i=0;i<n;i++)
{
scanf("%d",&t);
ans+=t;
}
printf("%d\n",ans);
}
return 0;
}
[/php]
A+B for Input-Output Practice (V)
Problem Description
Input
Output
Sample Input
Sample Output
Author
以下为c语言源码……………
[php]
#include<stdio.h>
int main()
{
int i,j,n,m,t,ans;
scanf("%d",&n);
for(i=0;i<n;i++)
{
scanf("%d",&m);
ans=0;
for(j=0;j<m;j++)
{
scanf("%d",&t);
ans+=t;
}
printf("%d\n",ans);
}
return 0;
}
[/php]
A+B for Input-Output Practice (VI)
Problem Description
Input
Output
Sample Input
Sample Output
Author
Recommend
以下为c语言源码……………
[php]
#include<stdio.h>
int main()
{
int i,ans,n,t;
while(scanf("%d",&n)!=EOF)
{
ans=0;
for(i=0;i<n;i++)
{
scanf("%d",&t);
ans+=t;
}
printf("%d\n",ans);
}
return 0;
}
[/php]
A+B for Input-Output Practice (VII)
Problem Description
Input
Output
Sample Input
Sample Output
author
Recommend
以下为c语言源码……………
[php]
#include<stdio.h>
int main()
{
int ans,a,b,t;
while(scanf("%d%d",&a,&b)!=EOF)
{
printf("%d\n\n",a+b);
}
return 0;
}
[/php]
A+B for Input-Output Practice (VIII)
Problem Description
Input
Output
Sample Input
Sample Output
Author
Recommend
以下为c语言源码……………
[php]
#include<stdio.h>
int main()
{
int i,j,n,m,t,ans;
scanf("%d",&n);
while (n–)
{
scanf("%d",&m);
ans=0;
while (m–)
{
scanf("%d",&t);
ans+=t;
}
printf("%d\n",ans);
if(n!=0)printf("\n");
}
return 0;
}
[/php]
1 comment
imeilige
November 10, 2012 at 8:09 am谢谢 对我太有帮助了